Drivers ATI 9.1

catalyst1

Ya están disponible una nueva versión de los drivers de ATI, concretamente la 9.1 que salió el 29 de Enero… Así que nos ponemos manos a la obra para instalarla.

La informaicón aquí mostrada, está disponible en inglés en la página (no-oficial) sobre la los drivers ATI en Linux, y  nos ayudará en el proceso de instalación.

INSTALACIÓN

1. Instalamos todas las dependencias necesarias, abrimos un terminal y tecleamos:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms

2. Vamos a la página oficial de ATI y descargamos el driver correspondiente a nuestra targeta, en mi caso lo descargo desde aquí. Guardamos el paquete en el escritorio.

3. En cuanto se haya descargado, vamos al terminal y nos colocamos en la carpeta donde hemos descargado el paquete. Para generar los paquetes .deb que son los que utilizaremos, se realiza con el comando:

sh ati-driver-installer-9-1-x86.x86_64.run –buildpkg Ubuntu/intrepid

4. Aquí tardará un rato, mientras se van generando varios paquetes .deb especificos para Ubuntu/intrepid que serán los que instalaremos. En realidad en este punto podemos elegir (cambiando el comando anterior) que distribución queremos actualizar y es por ello que se generan los paquetes especificos para esta.

5. En este punto, hay dos posibilidades, en el caso de que nuestro sistema sea de 32bits o de 64bits.

Sistema de 32 bits, para instalar los paquetes  .deb, hay que teclear:

sudo dpkg -i xorg-driver-fglrx_8.573-0ubuntu1_i386.deb fglrx-kernel-source_8.573-0ubuntu1_i386.deb fglrx-amdcccle_8.573-0ubuntu1_i386.deb

Sistema de 64 bits, para instalar los paquetes .deb, hay que teclear:

sudo dpkg -i xorg-driver-fglrx_8.573-0ubuntu1_amd64.deb fglrx-kernel-source_8.573-0ubuntu1_amd64.deb fglrx-amdcccle_8.573-0ubuntu1_amd64.deb

En este punto, ya tendremos instala la nueva versión de los drivers.

Sistemas de 64 Bits…

En caso de los sistemas de 64 bits, ase pueden producir algún problema de dependencias, por lo que utilizamos:

Actualizamos con:

sudo apt-get install -f

Forzamos que se sobreescriba los paquetes:

sudo dpkg -i –force-overwrite xorg-driver-fglrx_8.573-0ubuntu1_amd64.deb fglrx-kernel-source_8.573-0ubuntu1_amd64.deb fglrx-amdcccle_8.573-0ubuntu1_amd64.deb

Finalizando la instalación

Ahora que tenemos instalado los drivers, pasamos a configurarlos. Editamos el fichero /etc/X11/xorg.conf

sudo gedit /etc/X11/xorg.conf

Y en la sección Device, comprobamos que aparezca el Driver como “fglrx”, sino lo modificamos, quedando así (sin los […]):

Section “Device”
[…]
Driver “fglrx”
[…]
EndSection

Salimos y grabamos y a continuación escribimos:

sudo aticonfig –initial -f

Y también:

sudo aticonfig –input=/etc/X11/xorg.conf –tls=1

Para comprobar que todo ha ido perfecto, escribimos:

fglrxinfo

En el terminal aparece:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3650 AGP
OpenGL version string: 2.1.8395 Release

Con lo que ya lo tenemos todo listo.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s